< All Topics

Prerequisites (no longer needed on versions 5.2 and above)

Prerequisites installation is no longer needed on versions 5.2 and above.

Installing older versions please follow guide below:

  • Required prerequisites can be found on the ftp server: ftp.xcelgo.com
  • They should, ideally, be installed before Experior is installed.
  • Under the Prerequisites folder are three folders containing the software you might need to install.
  • Microsoft .NET 4.0 – This one is mandatory and should always be installed.
  • Microsoft DirectX 9.0c – Even if DirextX 10/11 is already installed.
  • NVIDIA PhysX – This only needs installing if your graphics chipset is not NVIDIA, for example it may be ATI. Otherwise updating your NVIDIA drivers will always give you the latest version of the PhysX software.
Was this article helpful?
How can we improve this article?
Please submit the reason for your vote so that we can improve the article.
Next System Requirements